Commit eaa08162 authored by Vincent Mazenod's avatar Vincent Mazenod
Browse files

freeze pip bootsrap3 + i18n = gettext to be fixed

parent fe7c3cec
......@@ -5,4 +5,4 @@ pelican.pid
srv.pid
blog_limos.egg-info
node_modules
venv
.venv
......@@ -16,7 +16,7 @@ build:
script:
- apt-get install -y --force-yes build-essential python-dev python-pip git nodejs nodejs-legacy npm
- pip install --upgrade pip==9.0.3
- pip install --editable .
- pip install -r requirements.txt
- cd content && npm install && cd ..
- sed -i "s/RELATIVE_URLS = True/RELATIVE_URLS = False/" pelicanconf.py
- apt-get install -y --force-yes locales
......
......@@ -2,7 +2,10 @@
## Installer les dépendances
```bash
sudo pip install --editable .
virtualenv -p /usr/bin/python3 .venv
source .venv/bin/activate
pip install -r requirements.txt
git submodule init
git submodule update --recursive --remote
```
......
appdirs==1.4.3
beautifulsoup4==4.5.3
blinker==1.4
docutils==0.13.1
feedgenerator==1.9
Jinja2==2.9.5
lxml==3.7.3
Markdown==2.6.8
MarkupSafe==0.23
packaging==16.8
pelican==3.7.1
Pygments==2.2.0
pyparsing==2.2.0
python-dateutil==2.6.0
pytz==2016.10
six==1.10.0
smartypants==2.0.0
typogrify==2.0.7
Unidecode==0.4.20
from setuptools import setup
setup(
name='blog-limos',
version='1.0',
include_package_data=True,
install_requires=[
'pelican',
'pygments',
'markdown',
'beautifulsoup4',
'typogrify'
]
)
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment